Service Health Dashboard

Real Device Testing affected

Resolved
RealDevices Testing
Partial Outage

We are currently experiencing some technical difficulties with our real device services. This has unfortunately resulted in some disruptions and test failures on real devices. Our dedicated team is actively working to resolve this issue with the utmost priority to ensure a swift return to normal service operation.

At LambdaTest, we take great pride in providing a reliable and efficient service. We sincerely apologize for any inconvenience this issue may have caused. Our Support Team stands ready to assist or provide additional information, should you need it. Thank you for your understanding, patience, and continued trust in our services.

2023-05-29T04:05:00.000Z
Resolved

Performance is back to normal and we'll continue to monitor it.