Service Health Dashboard

Dashboard Degraded Performance

Resolved
Automation Testing RealDevices Testing HyperExecute Testing
Degraded Performance

We are experiencing an issue in one of our backend services resulting in delayed responses on test dashboard. Running tests are working fine. Our team is looking actively on this to get resolved ASAP. We will update this page once the issue is fixed. We sincerely apologize for any inconvenience caused due to the issue.

2024-02-13T14:00:00.000Z
Resolved

The issue has been fixed now and we'll continue to monitor it.