Partial Outage
Resolved
RealDevices Testing
Partial Outage
Our US data center experienced a network outage from 11:30 PM UTC on May 13, 2025, to 2:00 AM UTC on May 14, 2025. During this window, you may have encountered connectivity issues or test failures. Our engineering team identified and resolved the problem promptly. We apologize for any inconvenience and appreciate your patience. If you need further assistance, please don't hesitate to contact our Support team.
2025-05-14T02:00:00.000Z
Resolved
The issue has been fixed, and we are actively monitoring it.