Service Health Dashboard | TestMu AI (Formerly LambdaTest)

Partial Degradation - iOS RealDevices

Resolved
RealDevices Testing KaneAI
Degraded Performance

We're currently experiencing degraded performance due to an ongoing Apple iOS App Store service disruption. We sincerely apologize for the inconvenience. For any questions or assistance, please reach out to our Support team.

https://developer.apple.com/system-status/#:~:text=App%20Store%20%2D%20In%2DApp%20Purchases%20%2D%20Resolved%20Outage

2026-09-01T13:15:00.000Z
Resolved

The issue has been resolved and we are actively monitoring.