Partial Degradation
Resolved
Automation Testing
Degraded Performance
We experienced a network issue in one of our US West data centers between 04:10 AM UTC and 04:30 AM UTC, which may have caused test cancellations for a subset of users. The impacted hosts have been isolated, and the issue has been fully resolved. There are no further test cancellations at this time.
2026-01-26T04:30:00.000Z
Resolved
The issue has been fixed now and we are actively monitoring it.