Degraded Performance
Resolved
Automation Testing
RealDevices Testing
Degraded Performance
We're currently experiencing a performance degradation in our U.S. data center that is affecting both Web Automation and Real Device services. You may notice test failures or intermittent connectivity issues as a result.
Please rest assured that our engineering team is investigating this at the highest priority and working toward a prompt resolution. We apologize for any disruption this may cause and appreciate your patience.
If you continue to encounter problems or need immediate assistance, don't hesitate to contact our Support team at support@lambdatest.com.
2025-06-13T11:45:00.000Z
Resolved
The issue has been fixed now and we are actively monitoring it.