Service Health Dashboard

Automation Degraded Performance

Resolved
Automation Testing
Degraded Performance

We are experiencing a blip in one of our backend services for the Web automation product resulting in tests going into queue. Our team is working on resolving this issue and restoring the service on utmost priority. We will update this page as soon as it will get resolved. Rest assured we are proactively managing the alerts in order to cater the best service possible. We sincerely apologize for any inconvenience caused due to the issue.

2023-09-27T19:00:00.000Z
Resolved

The issue has been fixed now and we'll continue to monitor it.