Partial Degradation
Resolved
Automation Testing
RealDevices Testing
Degraded Performance
We experienced a brief performance degradation in one of our services, impacting a subset of App Automation on Real and Virtual Devices, as well as Web Automation on Real Devices, between 7:25 AM UTC and 7:55 AM UTC. Our engineering team promptly identified the root cause and resolved the issue within this timeframe. We sincerely apologize for any inconvenience this may have caused. Our Support Team remains available to assist you further if needed, and we appreciate your continued trust and understanding.
2025-04-15T07:55:00.000Z
Resolved
The issue has been fixed now and we are actively monitoring it.