AWS Oregon Region Connectivity Issue
Resolved
Automation Testing
RealDevices Testing
HyperExecute Testing
KaneAI
Partial Outage
We experienced connectivity issues in the AWS Oregon region from 10:56 AM UTC to 11:19 AM UTC on July 24, 2026, which impacted multiple data centers. During this window, you may have encountered test initiation failures or intermittent connectivity errors. Our engineering team identified and resolved the issue promptly. We sincerely apologize for any inconvenience caused. For further assistance, please reach out to our Support team.
2026-07-24T11:19:00.000Z
Resolved
The issue has been resolved and we are actively monitoring.