Service Health Dashboard

Degraded Performance - Web Automation

Resolved
Automation Testing
Degraded Performance

We experienced an issue with one of our infrastructure providers, which affected inventory availability and may have caused test cancellations for a subset of users. The issue has been identified and fully resolved by our engineering team.

We sincerely apologize for any inconvenience caused. Please reach out to our Support Team for further assistance.

2026-04-28T19:37:00.000Z
Resolved

The issue has been resolved and we are actively monitoring.