Service Health Dashboard

Automation Degraded Performance

Resolved
Automation Testing RealDevices Testing
Partial Outage

We experienced degraded performance in US East region which has resulted in disruptions and test failures for automation tests from 12:30 AM UTC to 01:30 AM UTC. This is resolved now. We sincerely apologize for any inconvenience this issue may have caused. Our Support Team stands ready to assist or provide additional information. Thank you for your understanding, patience, and continued trust in our services.

2024-06-01T01:30:00.000Z
Resolved

The issue has been fixed now and we'll continue to monitor it.