Service Health Dashboard | TestMu AI (Formerly LambdaTest)

Degraded Performance - macOS Tests on HyperExecute and Web Automation

Resolved
HyperExecute Testing Automation Testing
Degraded Performance

Between 1:00 PM and 7:00 PM IST (07:30 - 13:30 UTC) on September 25, 2026, we experienced a partial degradation affecting macOS tests on HyperExecute and Web Automation. Customers may have experienced some test failures and issues with test artifacts.

Our Engineering and Platform teams actively investigated the issue and worked towards a resolution.

We sincerely apologize for the inconvenience and appreciate your patience and understanding while we worked to restore the affected services.

2026-09-25T13:30:00.000Z
Resolved

This issue has been resolved and we'll continue to monitor it.