Partial Degradation
Resolved
Automation Testing
Degraded Performance
We experienced a network issue in one of our data centers in the US East region from 07:50 AM UTC to 10:00 AM UTC, which may have caused some test cancellations for a subset of users. The issue has been identified and resolved, and all services are now fully operational.
We sincerely apologize for any inconvenience this may have caused. Our Support Team is available to assist you further if needed. Thank you for your continued trust and understanding.
2025-07-30T10:00:00.000Z
Resolved
The issue has been fixed now and we are actively monitoring it.