Partial Degradation
Resolved
Automation Testing
Degraded Performance
We experienced elevated infrastructure load in one of our data centers, which increased browser startup times for a subset of the latest browser versions.
As a result, some test sessions experienced delays during the setup phase. Tests configured with shorter session creation timeouts may have been cancelled before the browser setup was completed.
2026-07-17T00:30:00.000Z
Resolved
The issue has been fixed now and we are actively monitoring it.