Service Health Dashboard

Atlanta Region Inventory Outage

Resolved
Automation Testing Realtime Testing

We are experiencing Mac inventory outage in Atlanta Region due to a firewall upgrade activity from our Vendor side. You may experience machine busy or queue timeouts. Our apologies for the inconvenience caused. Please check our https://status.lambdatest.io/ for updates.

2021-11-21T08:30:48.878Z
Resolved

Atlanta Region inventory are back online and we'll continue to monitor.