Service Health Dashboard

Partial Degradation

Resolved
Automation Testing
Partial Outage

We are currently experiencing intermittent disruptions in the US West region due to power failure at one of our DC. Our dedicated team is actively working to resolve the issue.

2024-07-08T06:23:00.000Z
Resolved

The issue has been fixed now and we are actively monitoring it.