Service Health Dashboard | TestMu AI (Formerly LambdaTest)

Degraded Performance - RealDevices

Resolved
RealDevices Testing
Degraded Performance

We experienced an issue with one of our service, which affected test initiation and dashboard test loading problem. The issue has been identified and fully resolved by our engineering team.

We request you to reinitiate the skipped tests, also the test cases which were not loading on the dashboard those will get executed. We sincerely apologize for any inconvenience caused. Please reach out to our Support Team for further assistance.

2026-07-15T11:50:00.000Z
Resolved

The issue has been resolved and we are actively monitoring.