Service Health Dashboard

Degraded Performance

Resolved
RealDevices Testing
Degraded Performance

Due to a minor issue in one of our services, we have experience the test queuing problem. Our internal alerting system promptly detected the issue.

Our engineering team responded within a time and resolved this concern. We apologize for any disruption this may caused and we appreciate your patience.

If you continue to encounter problems or need immediate assistance, don't hesitate to contact our Support team at support@lambdatest.com.

2025-10-01T08:07:00.000Z
Resolved

The issue has been fixed now and we are actively monitoring it.