Service Health Dashboard

Network Latency

Resolved
Automation Testing RealDevices Testing Realtime Testing
Partial Outage

One of our DC partner is experiencing a network outage in US West region that may cause latency in running tests. We are in touch with DC team and will be updating you as soon as this is resolved.

2024-01-18T17:45:00.000Z
Resolved

Update: The issue is resolved from the DC end and the environment is stable now. We'll continue to monitor it. Please let us know in case you face any issues.