Service Health Dashboard

Web Automation Degraded Performance

Resolved
Automation Testing RealDevices Testing
Degraded Performance

One of our test management server was down due to sudden spike and affected queued and running test. We have removed the server and restored the service. Apologies for the inconvenience.

2024-01-11T17:20:00.000Z
Resolved

The issue has been fixed now and we'll continue to monitor it.