Downtime
Resolved
RealDevices Testing
HyperExecute Testing
KaneAI
Partial Outage
We experienced a downtime between 10:05 AM UTC to 10:30 AM UTC, impacting a subset of users across App and Web Automation on Real Devices, Manual Testing on Real Devices, Hyperexecute on Real Devices and KaneAI Mobile. Our engineering team has identified and promptly resolved the problem.
We sincerely apologize for any inconvenience this may have caused. Our Support Team remains available to assist you further if needed, and we appreciate your continued trust and understanding.
2025-06-05T10:30:00.000Z
Resolved
The issue has been fixed now and we are actively monitoring it.