Service Health Dashboard

RealTime Outage

Resolved
Realtime Testing
Partial Outage

RealTime testing experienced partial degraded performance from 09:30 UTC to 10:30 UTC during which users might have experienced increased latency when launching tests. The services are now operational, we apologize for any inconvenience caused during this period.

2024-04-17T10:30:00.000Z
Resolved

The issue has been fixed now and we'll continue to monitor it.